General slowness may be experienced on US east region
Incident Report for Artifactory Cloud
Resolved
This issue has now been resolved, the service performance on the US east region should now be normal.
Posted 5 months ago. Mar 01, 2017 - 12:27 UTC
Identified
Our US east cloud infrastructure is currently affected by service performance degradation. We are working to resolve this.
Posted 5 months ago. Mar 01, 2017 - 09:40 UTC